Mikrotik RB411 - Nastaveni DHCP serveru

<small>Z PVwiki</small>

Použité pojmy a zkratky:

  • RB = RouterBoard
  • PC = osobní počítač
  • MkT = OS MikroTik
  • eth = ethernet adaptér - zde přípojka RJ45 pro drátový přívod sítě-síťová karta
  • wlan = wireless adaptér - bezdrátová síťová karta
  • bridge = přímé spojení dvou a více síťových adaptérů bez překladu adres
  • bonding = svazek spojů, kdy dva a více spojů (bez ohledu na jejich typ ) je spojeno do svazku a zvýší se tak přenosová kapacita propojení bodů.

OS Mikrotik - Nastavení spoje AP - klient s routingem

Popisovaná konfigurace předpokládá základní znalost obsluhy konfiguračního programu winbox.exe , který slouží pro nastavování zařízení s běžícím systémem OS MikroTik. Program je určen pro prostředí OS Windows, ale funguje i v emulaci wine pod Linuxem . Tento konkrétní příklad byl nainstalován na hardware platformy Routerboard 411, kdy wlan1 je klientem proti AP a ether1 bude dodávat za NATem adresy klientům pomocí DHCP

  • Spustíme sw winbox
  • Klikneme na .. , vybereme zařízení které chceme konfigurovat. Pokud má zařízení nastavenou adresu v síti, do které "vidíme", může komunikace probíhat přes IP adresy na portu 20561, pokud ještě adresy nemá nebo ji neznáme, komunikuje s MAC na portu 8291 (zřejmě SNMP). U některých RB jsem narazil na základní adresu 192.168.88.1/24
  • Přednastavené uživatelské jméno admin, heslo je v základu prázdné - klik na Connect

Soubor:login.jpg


DHCP server může mimo běžného nastavení může být použit jako MikroTik RouterOS HotSpot pro autentizaci DHCP clientů. Více v HotSpot Manualu


obrázek ip-pool

obrázek dhcp-server1

obrázek dhcp-server2


Příklad nastavení funkce DHCP-Server MikroTik RouterOS z příkazové řádky.

Požadovaný balíček: dhcp
Licence nutná: Level1
Podúrovně: /ip dhcp-client, /ip dhcp-server, /ip dhcp-relay


Nastavení funkce DHCP-Server.

1.Vytvoření IP address pool

/ip pool add name=dhcp-pool ranges=172.16.0.10-172.16.0.20


2.Vlož DHCP network, která bude v rozsahu 172.16.0.0/12 a bude propagovat gateway s IP adresou 172.16.0.1 :

/ip dhcp-server network add address=172.16.0.0/12 gateway=172.16.0.1


3.A nakonec vyrob DHCP server:

/ip dhcp-server add interface=wlan1 address-pool=dhcp-pool


Příklad nastavení funkce DHCP-server na interface ether1, příděl adres z dhcp-clients IP pool na 2 hodiny:

/ip dhcp-server add name=dhcp-office disabled=no address-pool=dhcp-clients \
interface=ether1 lease-time=2h
[admin@MikroTik] ip dhcp-server> print
Flags: X - disabled, I - invalid
#   NAME             INTERFACE RELAY           ADDRESS-POOL LEASE-TIME ADD-ARP
0   dhcp-office      ether1                    dhcp-clients 02:00:00
[admin@MikroTik] ip dhcp-server>


Nastavení funkce DHCP-Client

1.Vytvoření DHCP klienta:

/ip dhcp-client add interface=wlan1 use-peer-dns=yes \
add-default-route=yes disabled=no

2.kontrola nastavení:

[admin@Server] ip dhcp-client> print detail
Flags: X - disabled, I - invalid
0   interface=wlan1 add-default-route=yes use-peer-dns=yes status=bound
address=172.16.0.20/12 gateway=172.16.0.1 dhcp-server=192.168.0.1
primary-dns=159.148.147.194 expires-after=2d23:58:52
[admin@Server] ip dhcp-client>


Příklad klienta na ether1

Přiřazení funkce DHCP client na interface ether1:

/ip dhcp-client add interface=ether1 disabled=no
[admin@MikroTik] ip dhcp-client> print detail
Flags: X - disabled, I - invalid
0   interface=ether1 add-default-route=no use-peer-dns=no status=bound
    address=192.168.25.100/24 dhcp-server=10.10.10.1 expires-after=2d21:25:12
[admin@MikroTik] ip dhcp-client>
Osobní nástroje